Rocky Linux 9 has a hard requirement on x86-64-v2. If the processor does not support it, system won't boot nor run. There's no workarounds as this is built into glibc.

What I would do is verify that the host supports x86-64-v2. You can do this by running something like:

/lib64/ --help | grep supported

If x86-64-v2 shows as supported, then the host CPU will work for 9. It'll be a matter of configuring your VM's to use the host CPU instead of emulating another. (Eg in KVM you'd use --cpu host on the CLI).

On Sat, Dec 10, 2022, 13:25 Jeremy Hansen via rocky <> wrote:
In an effort to troubleshoot this, I decided to launch a Rocky 8 vm and do a manual upgrade to Rocky 9.  While I understand this isn’t recommended, I thought perhaps it would reveal what the issue are.  After I started doing package upgrade, I noticed this:

Fatal glibc error: CPU does not support x86-64-v2

I suspect this is the root of my issues.  Can anyone explain this further?


On Friday, Dec 09, 2022 at 8:13 PM, Jeremy Hansen <> wrote:
I’m running Cloudstack and for unknown reasons, I’m having issues running Rocky 9. Kernel begins to boot and then it looks like it fails on loading initrd and I get a kernel oops.  Just curious if this is a known issue or if there’s a work around. I tried using the qcow2 image from Rocky as well and just using the install iso to create a new image. Same result. 

Rocky 8 works fine. 


rocky mailing list --
To unsubscribe send an email to